Login | Forgot password | Register


What is OpenID?

OpenID is an Internet-wide identity system that allows you to sign in to many websites with a single account.

With OpenID, your ID becomes a URL (e.g. http://username.myopenid.com/). You can get a free OpenID for example from myopenid.com.

For more information visit the official OpenID site.

191 Posts in 37 Topics by 33 members

Jump to:

Amiga OS Projects

Forums » Amiga OS Projects » Issues with RadeonHD.chip cards and Amiga OS motherboards

Please read the terms of service before posting. If this is your first visit, you will need to register before you can post. However, you can browse all messages below.

Page: 1 , 2 , 3 , 4 Go to End
Author Topic:Issues with RadeonHD.chip cards and Amiga OS motherboards 42583 Views
  • Raziel
    Community Member
    53 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post

    *sound of a mountain dropping from my heart*

    Stable again
    It seems i dislodged (like you assumed) the fan and heatsink from the cpu making it go over the top (luckily not enough to burn) and switching off...

    Reseated the heatsink and got rid of the SiL Controller (why do i have a fixed system when i'm not using it?) ;-)

    I'll try and use the other card now, lets see what comes out of it

    EDIT 1:

    1) Card is booting up with the other monitor displaying the cursor ... YAY
    2) Working with both the VGA and DVI outputs
    3) Radeon HD displaying UBoot and the boot pic, but...

    1) ..as far as the Workbench is ought to show up it locks up solid (that is, the bootpic is locking up)
    2) Booting with the Radeon 9200 and TESTing a RadeonHD screenmode in the screenmode prefs, brings up the Preview Mode but locks up solid again (I got as far as counting down 2 seconds in a 1024x768 mode before it locked)
    3) Changing Interrupts to NO in the RadeonHD monitor drivers tooltypes doesn't change anything


    EDIT 2:

    I set up a serial link to the old PC i got standing here and what do you know i get output.
    The following is NOT from the serial link, but rather taken from DumpDebugBuffer (luckily it logged it once when the card was in place, but NOT booted from/to)...here is the output:

    RadeonHD (2): Unknown card detected: 0x94CC:0x1787:0x2256.
    RadeonHD (2): If - and only if - your card does not work or does not work optimally
    please contact Hans de Ruiter at hans --- hdrlab.org.nz to help rectify this.
    Use the subject: 0x94CC:0x1787:0x2256: <name of board>
    and *please* describe the problems you are seeing
    in your message.
    RadeonHD.chip (0): Object: ID: 310F name: 7PIN_DIN type: 3 id: F
    RadeonHD.chip (0): Object: ID: 3105 name: VGA type: 3 id: 5
    RadeonHD.chip (0): Object: ID: 3102 name: DUAL_LINK_DVI_I type: 3 id: 2
    RadeonHD.chip (0): Memory controller is not idle, can't set up MC
    RadeonHD.chip (0): RadeonHD card successfully opened
    RadeonHD.chip (0): UBoot has not initialized the graphics card's interrupt line. Disabling interrupts.
    RadeonHD.chip (0): Please upgrade your UBoot firmware.

    I REALLY hope you can do something with this output, i obviously can not ;-)

    UBoot 1.1.1 (Mar 3 2005 - 16:42:53)

    AOneXE 7447/7457 1266MHz (USB & DMA fixed)
    512 MB Crucial (CT64M72S4R75) RAM
    Sapphire Radeon 9200 (AGP)
    Club 3D Radeon HD 2400 Pro (PCI)
    Sigmatel AC97 (refitted, using to play MIDI through a Roland MT-32 device)
    Terratec Aureon 7.1 (Envy24HT)

    EDIT 3:

    and here is finally the output from the serial link (not much in there i�´m afraid)

    U-Boot 1.1.1 (Mar 3 2005 - 16:42:53), Build: 03/03/05

    CPU: MPC7457 v1.2 @ 1266.666 MHz
    Board: AmigaOne
    Information for SIMM bank 0:
    Number of banks: 1
    Number of row addresses: 13
    Number of coumns addresses: 11
    SIMM is registered
    Supported burst lenghts: 8 4 2 1 PAGE
    Supported CAS latencies: CAS 3 CAS 2
    RAS to CAS latency: 3
    Precharge latency: 3
    SDRAM highest CAS latency: 750
    SDRAM 2nd highest CAS latency: 1000
    SDRAM data width: 4
    Auto Refresh supported
    Refresh time: 1042 clocks
    Bank 0 size: 512 MB

    Slot 1: vacant
    DIMM0_B0_SCR0 = 0x00ff9f00
    DIMM0_B1_SCR0 = 0x007f9f00
    DIMM0_B2_SCR0 = 0x007f9f00
    DIMM0_B3_SCR0 = 0x007f9f00
    Using CAS 3 (slow)
    DRAM_GCR0 = 0x00550400
    Refresh set to 2083 clocks, auto refresh on
    DRAM_REFRESH0 = 0x00019823
    Mode bank 0: 0x00008032
    512 MB
    FLASH: 0 kB
    VGA: 0 ..
    1 ..
    In: serial
    Out: serial
    Err: serial

    ...me wonders when the sun rises in New Zealand :-?

    EDIT: Obfuscated the email address in the log. I'd rather not have a spam bot read it.

    If slaughterhouses had glass walls, everyone would be a vegetarian ~ Paul McCartney
    AmigaOS4 does not have bugs -- it just develops random features ;-)

  • Hans
    231 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post


    I'm glad that your machine is fine.

    I'm surprised that it locks up on attempting to open a screen. Please download and use the debug version, and send me the debug log via email, or via the private beta testers forum (i.e., not here). When you do, be sure to write down which output your monitor was connected to.

    The time difference between New Zealand and Western Europe is 10 hours, with NZ 10 hours into the future. ;-) That does make coordinating things "interesting" at times.


    EDIT: Oh, read this guide on how to get Amiga OS to redirect debug output to the serial port on startup, it's really useful for startup issues.

  • BigMac
    Community Member
    2 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post

    Hardware:- Sam Flex 800mhz 1gig ram ATI Radeon 1550 512m pci graphics card.
    Booted Sam using Radeon 9800 pci and proceeded to install new driver.(At the moment I am using a standard vga 19in monitor) Driver began to install and locked up system at 83% completed I tried this installation method at least five times to no avail the installion kept on locking up the computer at 83% after having a look at the kickstart dir I found that the new drivers were in fact installed however the kicklayout had not been changed so I changed it manually to initialise the new driver a very simple task or as I would say no big deal. On completion
    and after checking everything I shutdown the computer and after installing the Radeon 1550 and connecting the monitor I applied power and the computer began to boot after a few seconds I was presented with a flashing cursor on the top LH side of the screen and after a few more seconds this cursor was replaced with a garbled but readable Acube logo:) which dissapeared quite quickly to a blank screen with no visible hd activity. After about 12 seconds my monitor resynced twice and up popped the initial OS4,1 screen and then nothing the Sam just froze I tried to boot 3 or 4 times and received the same result each time. What next I rechecked everything and all looked ok! I then decided to remove one of the Sam ram modules (1gig seems to be problematic on the Flex) and rebooted everything went exactly as before except that this time my HDrive activity led was being accessed as normal and OS 4.1 booted straight to workbench. I have had minimal time to really test everything but all drawers and folders open and close normally with no graphics corruption and the few programs I did run work perfectly:)

    What next?

    Reinstall OS4.1 and try the driver installation program again Hans said it does'nt need the new Radeon chip to install so I,ll delve into this and hopefully it will work as it should.

    I will try to boot using my new monitor (picking up tomorrow) and the HD connector should work hopefully.

    And lastly try to get the rig running using 1 gig memory although I have a feeling this is OS related or could it be a flaw in the board design hope not anyway:)
    Lastly I hope my ramblings will help to get a few more Sams up and running Hans has put a great deal of work into this driver so lets all give him as much help as we can seeya.

  • Magic
    Community Member
    11 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post

    Thank you BigMac for the tips. Just a couple notes as I am short on time, will post more later. Sam Flex 667Mhz with 512 Megs (didn't even try with the second memory module) tried a Powercolor PCI HD2400 256 DDR2 as the primary card. A quick test wouldn't output video from either my Radeon 9250 or the 2400 if they were both installed (using the DVI ports) in the machine at the same time. Uboot 1.3.1 recognizes the HD2400 just fine. The Acube Graphic and initial config info displays fine.

    The beta driver installation froze at 83% for me also. I modified the Kicklayout file to load the RadeonHD.chip module, shut down and switched the cards. This time it booted up to workbench in default 640x480 mode in what looked like about 8 colors. I selected 1440x900 (Samsung Syncmaster 932BW DVI port). The screen refresh was really slow and the windows were corrupted badly. I turned of compositing in the GUI prefs and that seemed to solve the screen corruption. Everything "Feels" much slower now than with my 9250 installed. Screen refresh is slower, windows re-size much slower, scrolling in a large windows is REALLY slow, icons load in windows slower, ect. It is usable though and looks nice. The mouse pointer is kind of a pinkish purple now too. I hope I can provide some help. I'll try and capture some debug output this weekend if I can get the time.

  • Hans
    231 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post

    Hi Magic,

    I'll wait for your debug logs; please email them, or post them in the private beta tester forum (email is better in this case).

    The mouse pointer colour issue will be fixed in the next beta. The compositing related issues are due to lack of hardware compositing. There seems to be some kind of software backup, but it's not perfect.

    I'd just like to remind everyone using a Radeon HD 2400, that the driver currently has no hardware acceleration at all for these cards. This is why it's so slow, particularly with high resolutions; the CPU has to do all the work and copy data to/from the graphics card. Radeon X1300 and Radeon X1550 users have the benefit of hardware accelerated blitter operations, so their systems should run faster. Once I have finished compositing for the Radeon X1000 series (after I fix the bugs that beta testers have found), I'll move on to hardware acceleration for the R600.


  • Magic
    Community Member
    11 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post

    As soon as I figure out which is the easiest way to capture the logs I will email them to you.

    Fantastic work so far!

  • Hans
    231 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post


    Seeing as you have a working display, "dumpdebugbuffer ram:log.txt clear" should do nicely, unless the debug buffer is huge. The serial port is only necessary when the debug logs are huge, or the system freezes and requires a hard reset.

    Seeing as you've got the card displaying, you can probably add an entry to the "Cards that work" thread: http://hdrlab.org.nz/amiga-os-projects/show/18#post18


  • Magic
    Community Member
    11 Posts

    Re: Issues with RadeonHD.chip cards and Amiga OS motherboards Link to this post

    I sent the debug log to you via email.

Go to Top

Currently Online: There is nobody online.

Welcome to our latest member: SeregaRit

Forums » Amiga OS Projects » Issues with RadeonHD.chip cards and Amiga OS motherboards